Issue currently under investigation

Major Incident Content Platform - CH01
44 minutes

Update

Resolved

The issue was resolved. Apologies again for any inconvenience.

May 7th, 2020 at 11:19 CEST
Issue

There are problems with the SSL certificate of the picturepark.com domain. We are currently investigating this and will update you here. Apologies for any inconvenience.

May 7th, 2020 at 10:39 CEST