Issue currently under investigation

Major Incident Content Platform - CH01
1 hour, 29 minutes

Update

Resolved

The issue has now been resolved. Apologies for any inconvenience.

May 20th, 2020 at 01:43 CEST
Issue

The platform is currently unavailable. We are currently investigating this and will update you here. Apologies for any inconvenience.

May 20th, 2020 at 01:02 CEST