Video Playback Issues

Minor incident Content Platform - CH01
2021-06-08 12:21 CEST · 53 minutes, 9 seconds

Updates

Resolved

This issue has been resolved.

June 8, 2021 · 13:14 CEST
Issue

We’re experiencing video playback issues and hope to have this resolved shortly. As a workaround, you might want to use other preview formats via download.

June 8, 2021 · 12:29 CEST

← Back