Investigating Issue

Major Incident Content Platform - CH01
1 hour, 37 minutes

Update

Resolved

The issues have been resolved. We apologize for any inconvenience caused and thank you for your understanding

January 14th, 2020 at 21:56 CEST
Issue

Platform not available

January 14th, 2020 at 20:21 CEST