Service Degradation

Minor incident Content Platform - CH01
4 minutes, 46 seconds

Updates

Investigating

The issue has been resolved. Thank you for your patience.

February 17, 2020 · 10:48 CET
Issue

We are investigating an issue with user authentication. Apologies for the inconvenience.

February 17, 2020 · 10:44 CET

← Back